Connexion  

   

Annexes  

   
   

Note utilisateur: 0 / 5

Etoiles inactivesEtoiles inactivesEtoiles inactivesEtoiles inactivesEtoiles inactives
 

Ci-dessous la procédure utilisée pour installer le copmilateur GCC V7.0.2 sur AIX V7.1 TL4 SP2 1614.

 

 

1.     Introduction.

Le but de l’opération consiste à installer le compilateur sur une LPAR en AIX V7.1TL4SP21614.

Déroulement des opérations :

  • Récupération des fichiers RPM sur le serveur NIML1 ( /nim/source/software/GCC702)
  • Recopie dans /tmp/GCC sur le serveur cible.
  • Lancement de l’installation avec UPDATE et '--nodeps' si nécessaire des RPMS : rpm -Uvh nom1.rpm nom2.rpm ... --nodeps

Liste des RPMS :

bash-4.4-3.aix6.1.ppc.rpm

gcc-7.2.0-6.aix7.1.ppc.rpm

gcc-cpp-7.2.0-6.aix7.1.ppc.rpm

gettext-0.19.8-1.aix6.1.ppc.rpm

glib2-2.48.1-2.aix6.1.ppc.rpm

gmp-6.1.1-1.aix6.1.ppc.rpm

info-5.0-2.aix6.1.ppc.rpm

libffi-20170516-1.aix6.1.ppc.rpm

libgcc-7.2.0-6.aix7.1.ppc.rpm

libiconv-1.14-22.aix6.1.ppc.rpm

libmpc-1.0.3-2.aix6.1.ppc.rpm

libstdc++-7.2.0-6.aix7.1.ppc.rpm

libunistring-0.9.6-2.aix6.1.ppc.rpm

libxml2-2.9.4-2.aix6.1.ppc.rpm

mpfr-3.1.4-1.aix6.1.ppc.rpm

ncurses-6.0p20160730-1.aix6.1.ppc.rpm

xz-libs-5.2.2-2.aix6.1.ppc.rpm

zlib-1.2.8-3.aix6.1.ppc.rpm

# rpm -Uvh bash-4.4-3.aix6.1.ppc.rpm gcc-7.2.0-6.aix7.1.ppc.rpm gcc-cpp-7.2.0-6.aix7.1.ppc.rpm gettext-0.19.8-1.aix6.1.ppc.rpm glib2-2.48.1-2.aix6.1.ppc.rpm gmp-6.1.1-1.aix6.1.ppc.rpm info-5.0-2.aix6.1.ppc.rpm libffi-20170516-1.aix6.1.ppc.rpm libgcc-7.2.0-6.aix7.1.ppc.rpm libiconv-1.14-22.aix6.1.ppc.rpm libmpc-1.0.3-2.aix6.1.ppc.rpm libunistring-0.9.6-2.aix6.1.ppc.rpm libxml2-2.9.4-2.aix6.1.ppc.rpm mpfr-3.1.4-1.aix6.1.ppc.rpm ncurses-6.0p20160730-1.aix6.1.ppc.rpm xz-libs-5.2.2-2.aix6.1.ppc.rpm zlib-1.2.8-3.aix6.1.ppc.rpm libstdc++-7.2.0-6.aix7.1.ppc.rpm --nodeps

package info-5.0-2 is already installed

package libffi-20170516-1 is already installed

package libiconv-1.14-22 is already installed

package xz-libs-5.2.2-2 is already installed

# gcc

gcc: no input files

            Liste des RPMS après :

rpm -aq|sort

AIX-rpm-7.1.4.0-1

bash-4.2-3

bzip2-1.0.5-3

coreutils-5.2.1-2

expat-2.1.0-1

gcc-4.2.0-3

gzip-1.2.4a-10

info-5.0-2

less-382-1

libevent-2.0.21-1

libffi-20170516-1

libgcc-4.8.3-1

libiconv-1.14-22

lsof-4.87-1

ncurses-5.9-1

nrpe_nsca_and_plugins-pmu-1.3-8

nrpe_nsca_and_plugins-std-1.01-1

ocsinventory-agent-2.1.1-1

openssl-1.0.1e-2

puppet-agent-aix-3.8.6-4

puppet-ruby-2.0.0-p353

pwmgmt-1.1-1

readline-6.1-1

rsync-3.0.6-1

screen-3.9.10-2

sed-4.1.1-1

sudo-1.8.10p3_pmu-1.1

tar-1.22-1

tcl-8.4.7-3

tk-8.4.7-3

tmux-1.8-1

traceroute-1.4a12-2

unzip-5.51-1

vim-common-6.3-1

vim-enhanced-6.3-1

watch-3.2.8-1

wget-1.9.1-2ssl

xz-libs-5.2.2-2

zip-2.3-3

zlib-1.2.8-1

   
   
© ALLROUNDER