Connexion  

   

Annexes  

   
   

Note utilisateur: 0 / 5

Etoiles inactivesEtoiles inactivesEtoiles inactivesEtoiles inactivesEtoiles inactives
 

 

# rpm -ivh curl-7.58.0-1.aix6.1.ppc.rpm
error: Failed dependencies:
libssh2 >= 1.8.0-1 is needed by curl-7.58.0-1.ppc
ca-certificates >= 2016.10.7 is needed by curl-7.58.0-1.ppc
libcrypto.a(libcrypto.so) is needed by curl-7.58.0-1.ppc
liblber.a(liblber-2.4.so.2) is needed by curl-7.58.0-1.ppc
libldap.a(libldap-2.4.so.2) is needed by curl-7.58.0-1.ppc
libssh2.a(libssh2.so.1) is needed by curl-7.58.0-1.ppc
libssl.a(libssl.so) is needed by curl-7.58.0-1.ppc

 

Pour la version 7.51 :

Récupération sur bullfreeware
Archive: curl-7.51.0-2ldapssl.aix6.1.ppc.rpm-with-deps.zip
inflating: db-4.8.24-4.aix6.1.ppc.rpm
inflating: gdbm-1.10-1.aix6.1.ppc.rpm
inflating: unixODBC-2.3.1-1.aix6.1.ppc.rpm
inflating: info-5.0-2.aix6.1.ppc.rpm
inflating: libiconv-1.14-22.aix6.1.ppc.rpm
inflating: readline-6.3-1.aix6.1.ppc.rpm
inflating: libunistring-0.9.6-2.aix6.1.ppc.rpm
inflating: zlib-1.2.8-3.aix6.1.ppc.rpm
inflating: ncurses-6.0p20160730-1.aix6.1.ppc.rpm
inflating: libidn-1.33-1.aix6.1.ppc.rpm
inflating: xz-libs-5.2.2-2.aix6.1.ppc.rpm
inflating: bash-4.4-3.aix6.1.ppc.rpm
inflating: libxml2-2.9.4-2.aix6.1.ppc.rpm
inflating: curl-7.51.0-2ldapssl.aix6.1.ppc.rpm
inflating: openldap-2.4.44-5.aix6.1.ppc.rpm
inflating: gettext-0.19.8-1.aix6.1.ppc.rpm
inflating: glib2-2.48.1-2.aix6.1.ppc.rpm
inflating: libffi-20170516-1.aix6.1.ppc.rpm
inflating: libssh2-1.4.2-2.aix6.1.ppc.rpm
inflating: libgcc-7.2.0-6.aix6.1.ppc.rpm
inflating: libstdc++-7.2.0-6.aix6.1.ppc.rpm
inflating: perl-5.24.0-3.aix6.1.ppc.rpm
inflating: openssl-1.1.0g-1withsslv2.aix6.1.ppc.rpm
# rpm -ivh curl-7.51.0-2ldapssl.aix6.1.ppc.rpm
error: failed dependencies:
openssl >= 1.0.2g is needed by curl-7.51.0-2ldapssl
libidn >= 1.24 is needed by curl-7.51.0-2ldapssl
libssh2 >= 1.2.7 is needed by curl-7.51.0-2ldapssl
libcrypto.a(libcrypto.so.1.0.2) is needed by curl-7.51.0-2ldapssl
liblber.a(liblber-2.4.so.2) is needed by curl-7.51.0-2ldapssl
libldap.a(libldap-2.4.so.2) is needed by curl-7.51.0-2ldapssl
libssh2.a(libssh2.so.1) is needed by curl-7.51.0-2ldapssl
libssl.a(libssl.so.1.0.2) is needed by curl-7.51.0-2ldapssl
# rpm -Uvh openssl-1.1.0g-1withsslv2.aix6.1.ppc.rpm
openssl ##################################################
rpm_share: 0645-024 Unable to access directory /etc/sudoers.d
rpm_share: 0645-007 ATTENTION: update_dir() returned an unexpected result.
rpm_share: 0645-007 ATTENTION: update_inst_root() returned an unexpected result.

# rpm -ivh libidn-1.33-1.aix6.1.ppc.rpm libssh2-1.4.2-2.aix6.1.ppc.rpm gettext-0.19.8-1.aix6.1.ppc.rpm --nodeps

 

# rpm -ivh openldap-2.4.44-5.aix6.1.ppc.rpm --nodeps

# rpm -ivh curl-7.51.0-2ldapssl.aix6.1.ppc.rpm

NOTE : Installer aussi libgcc-7.1.0-7.aix7.1.ppc.rpm à la place du produit proposé( libgcc-7.2.0-6.aix6.1.ppc.rpm)

Tester :

curl -H "Accept: application/json"
curl: no URL specified!
curl: try 'curl --help' or 'curl --manual' for more information

 

Résumé des produits installés :

AIX-rpm-7.1.5.0-2
bash-4.2-3
bzip2-1.0.5-3
coreutils-5.2.1-2
curl-7.51.0-2ldapssl
expat-2.1.0-1
gcc-4.2.0-3
gettext-0.19.8-1
gzip-1.2.4a-10
info-5.0-2
less-382-1
libevent-2.0.21-1
libffi-20170516-1
libgcc-7.1.0-7
libiconv-1.14-22
libidn-1.33-1
libssh2-1.4.2-2
lsof-4.87-1
ncurses-5.9-1
nrpe_nsca_and_plugins-pmu-1.3-8
nrpe_nsca_and_plugins-std-1.01-1
ocsinventory-agent-2.1.1-1
openldap-2.4.44-5
openssl-1.1.0g-1withsslv2
puppet-agent-aix-3.8.6-4
puppet-ruby-2.0.0-p353
pwmgmt-1.1-1
readline-6.1-1
rsync-3.0.6-1
screen-3.9.10-2
sed-4.1.1-1
sudo-1.8.10p3_pmu-1.1
tar-1.22-1
tcl-8.4.7-3
tk-8.4.7-3
tmux-1.8-1
traceroute-1.4a12-2
unzip-5.51-1
vim-common-6.3-1
vim-enhanced-6.3-1
watch-3.2.8-1
wget-1.9.1-2ssl
xz-libs-5.2.2-2
zip-2.3-3
zlib-1.2.8-1

   
   
© ALLROUNDER