Formule 3+2

Un système informatique mérite d'être suivi…

AHIX et ses services

AHIX Technologies
89330 Saint Loup d'Ordon
Votre nouveau…

Conseil et assistance informatique

 
Consultant spécialisé dans les systèmes AIX…

Support et informations

AHIX Technologies apporte le support aux administrateurs…

lswpar : Liste des limites de ressources WPAR

La commande 'lswpar -R MyWpar' permet de lister les limites…

Reprise de vos vieux matériels

 
En cette période de propreté planétaire, ne…

Support technique continu pour AIX pseries.

AHIX Technologies vous propose des formules de support…

pwdadm pour effacer les drapeaux liés à un compte


La commande 'pwdadm' permet de gérer les mots de…

Erreur OpenSSL lors de la MAJ 7.1TL5-SP1-1731

Lors de la mise à jour AIX en TL5-SP1, avec le passage en…

AH01630: client denied by server configuration

Lors de l'accès au serveur LPAR2RRD, vous pouvez…

1 2 3 4 5 6 7 8 9 10
Etoiles inactivesEtoiles inactivesEtoiles inactivesEtoiles inactivesEtoiles inactives
 

Lors de la mise à jour AIX en TL5-SP1, avec le passage en version 7.1 de OpenSSL, une erreur se produit lors de l'installation de la nouvelle version d'OpenSSL:

ar: Error 0
ar: 0707-114 The fread system call failed.
x - /usr/lib/libssl.so
x - /usr/lib/libcrypto.so
Finished processing all filesets. (Total time: 5 secs).

ou en mode détaillé : 

ar: Error 0
ar: 0707-114 The fread system call failed.
x - /usr/lib/libssl.so
x - /usr/lib/libcrypto.so
sysck: 3001-049 Wrong file size. The file
/usr/lib/libssl.a
has an actual size of 0 bytes (expected size: 0 bytes).
sysck: 3001-017 Errors were detected validating the files
for package openssl.base.

CELA PROVIENT DU FAIT QUE LE FICHIER /usr/lib/libssl.so pointe sur /usr/lib/libssl.a qui n'existe plus après la désinstallion de openssl.base (ancienne version)

root/master-aix:/usr/lib#ls -l libssl*
lrwxrwxrwx 1 root system 17 Feb 23 17:51 libssl.so -> /usr/lib/libssl.a
lrwxrwxrwx 1 root system 31 Feb 5 14:31 libssl3.a -> /usr/opt/freeware/lib/libssl3.a
lrwxrwxrwx 1 root system 32 Feb 5 14:31 libssl3.so -> /usr/opt/freeware/lib/libssl3.so

 

Il est donc nécessaire de supprimer le lien /usr/lib/libssl.so

Un palliatif à cette erreur d'installation consiste à :

- sauvegarder le programme /usr/bin/sysck en /usr/bin/sysck.old

- Créer un script /usr/bin/sysck avec les bons droits :

#!/bin/ksh

exit 0

Puis relancer l'installation.

Attention, l'installation de l'installeur ( bos.rte.install) remplace le script temporaire. penser donc à installer d'abord ce fileset avant de faire l'update_all.

A la fin de l'installation, la librairie est toujours vide. Il faut donc la restaurer du fileset d'origine 'openssl.base.1.0.2.1100.I' :

# restore -T -f openssl.base.1.0.2.1100.I    # pour consulter les fichiers

# restore -d . -x -f openssl.base.1.0.2.1100.I ./usr/lib/libssl.a  # pour restaurer dans le répertoire courant...

 

 

 

 

 

loading...
Articles Récents